SweetFX Settings DB
Latest forum threads
4 minutes ago
13 minutes ago
44 minutes ago
59 minutes ago
The Witcher 3: Bugged Textures with SMAA
Posted 8 years, 11 months ago
I'm currently running The Witcher 3 on a GTX980 with almost all settings maxed and the only thing that detracts from the experience a bit is the lackluster antialiasing that the game offers. So I decided to inject SMAA but since the original injector doesn't work with 64bit games I decided to use the SMAA included in sweetfx using boulotaur's injector. At first everything looked great but then I ran into problems with missing textures on models: [Possible minor spoilers] For example during the cutscene when entering novigrad the man who is burned at the stake has no face. I can see his body, his hair but the rest of the head is simply missing. reloading and viewing the cutscene without SMAA solves the problem. There's also a certain kind of monster "Hound of the Wild Hunt" spawned during a boss fight that will simply appear invisible although sometimes a few faulty textures will spasm around in the general area (it seems the bug might only affect creatures made out of multiple model parts as the hounds have a kind of frost layer on them). I did some more tests during the fight. With SMAA all hounds that spawn will be invisible. Turning smaa off won't fix the already spawned monsters but if another hound spawns after the effect is turned off it will look normal even if SMAA is turned on again. However this will cause the next hound that spawns to have missing textures again. [/end of possible spoilers] After this I turned to ReShade 1.9 with SweetFX and it turned out that the bug stopped occurring. However the SMAA effect with Reshade simply looked horrible. It was way too rough it was like it was applied multiple times, Text would appear much fatter with all kinds of garbage around the edges, (ironically with the normal sweetfx the effect was quite the oppossite, text would appear a little bit thinner although it was not really that distracting)and generally edges would appear grainy rather than smooth. I pretty much experimanted with every setting I could find but none of the options (not even the new ones added in reshade) helped with the annoying effects, the appearrance would change a bit sometimes but it would always have that roughness and none of the smoothness of the old SMAA. I really wish there was a way just to force the old faishioned HIGH or ULTRA SMAA presets with reshade, that's pretty much all I need. edit: I also tried FXAA it didn't bug out but it the typical bluriness just doesn't work well with the game's inbuilt sharpening and just ended up looking bad.
Posted 8 years, 9 months ago
Did you install Sweetfx/Reshade with the auto installer located in the unzipped Sweetfx folder, or manually? I ask because there is an extra step with the new Sweetfx 2.0 and Reshade that requires you to rename Reshade64.dll to dxgi.dll. Also, make sure your files are in the correct directory. Bin folder? I think there is a 64 bit sub directory in there... I forget Good luck!
Posted 8 years, 9 months ago
Also, Run "Reshade Setup.exe" from within your unzipped Sweetfx Folder, then select the game "Witcher3.exe" that is in Bin\x64. It should work..
New post

Please log in to post an answer