SweetFX Settings DB
Latest forum threads
1 minute ago
2 minutes ago
6 minutes ago
20 minutes ago
SweetFx 2.0 + reShade fail w/o logging an error
Posted 8 years, 3 months ago
TL;DR: Game closes during "Compiling Effects..."; Log ends with "Loading effect from "C:\Program Files (x86)\Turbine\The Lord of the Rings Online\ReShade.fx" ... Any help would be greatly appreciated as I am all out of ideas. I have spent hours trying to get sweetFx 2.0 + reShade to work with no avail. I am trying to get it to work with LOTRO which it seems plenty of people can do without issues. When the game turns on I get the black screen with reShade in the top right compiling effects. Then it just closes to desktop without any error. There isn't even an error in the dxgi log, The last action written is getting effects from ...\Lord of the Rings Online\reShade.fx... I tried using just sweetFx 1.5.1 but that was a disaster. The game wouldn't even start after clicking play from the launcher and nothing was written to the log. All the details: I am running a fresh install of Win 10 on a brand new computer using a nVidia 980 ti. I have updated all drivers and installed C++ 2012 redistributable and .NET 4.5 My dxdi log has no errors and only the two warnings: | WARN | Reference count for 'IDXGIDevice' object 06B09480 is inconsistent: 2 vs 0. | WARN | Reference count for 'ID3D11Device' object 01F10678 is inconsistent: 1 vs 0. The game runs fine w/o sweetFx. I have tried changing my in-game directX settings down and running dx9 with the same results. I made sure security setting were correct for these files; full control and files are not read-only. I have ran the game as administrator and granted write permissions to the sweetFx files and folders. I have tried using the 32-bit version of reShade. I have tried renaming the dxgi.dll file to d3d11.dll. I have made sure there were no overlays running. I have tried removing the game completely and running ccleaner before a fresh install. I am wondering if it somehow has to do with this being a new OS install and I am missing something simple. As you see I am out of ideas and grasping at straws at this point. Any help would be really appreciated! dxgi log: (Don't mind the dates, this isn't my log but has the same messages as mine) 30/09/2015 13:03:17:461 [06928] | INFO | Initializing Crosire's ReShade version '0.18.7.868' built on '2015-06-04 17:18:22' loaded from "F:\Program Files (x86)\Turbine\The Lord of the Rings Online\dxgi.dll" to "C:\Program Files (x86)\Turbine\The Lord of the Rings Online\lotroclient.exe" ... 30/09/2015 13:03:17:493 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d8.dll" ... 30/09/2015 13:03:17:493 [06928] | INFO | > Delayed. 30/09/2015 13:03:17:493 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d9.dll" ... 30/09/2015 13:03:17:493 [06928] | INFO | > Delayed. 30/09/2015 13:03:17:493 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10.dll" ... 30/09/2015 13:03:17:493 [06928] | INFO | > Libraries loaded. 30/09/2015 13:03:17:494 [06928] | INFO | > Found 2 match(es). Installing ... 30/09/2015 13:03:17:511 [06928] | INFO | > Installed 2 hook(s). 30/09/2015 13:03:17:511 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d10_1.dll" ... 30/09/2015 13:03:17:511 [06928] | INFO | > Delayed. 30/09/2015 13:03:17:511 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\d3d11.dll" ... 30/09/2015 13:03:17:511 [06928] | INFO | > Libraries loaded. 30/09/2015 13:03:17:512 [06928] | INFO | > Found 2 match(es). Installing ... 30/09/2015 13:03:17:528 [06928] | INFO | > Installed 2 hook(s). 30/09/2015 13:03:17:528 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\dxgi.dll" ... 30/09/2015 13:03:17:528 [06928] | INFO | > Delayed. 30/09/2015 13:03:17:528 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\opengl32.dll" ... 30/09/2015 13:03:17:528 [06928] | INFO | > Delayed. 30/09/2015 13:03:17:528 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\user32.dll" ... 30/09/2015 13:03:17:528 [06928] | INFO | > Libraries loaded. 30/09/2015 13:03:17:539 [06928] | INFO | > Found 5 match(es). Installing ... 30/09/2015 13:03:17:578 [06928] | INFO | > Installed 5 hook(s). 30/09/2015 13:03:17:578 [06928] | INFO | Registering hooks for "C:\WINDOWS\system32\ws2_32.dll" ... 30/09/2015 13:03:17:578 [06928] | INFO | > Libraries loaded. 30/09/2015 13:03:17:580 [06928] | INFO | > Found 8 match(es). Installing ... 30/09/2015 13:03:17:641 [06928] | INFO | > Installed 8 hook(s). 30/09/2015 13:03:17:642 [06928] | INFO | Initialized. 30/09/2015 13:03:17:643 [06928] | INFO | Redirecting 'CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 0019F9A8)' ... 30/09/2015 13:03:17:645 [06928] | INFO | Installing delayed hooks for "C:\WINDOWS\system32\dxgi.dll" ... 30/09/2015 13:03:17:645 [06928] | INFO | > Found 3 match(es). Installing ... 30/09/2015 13:03:17:645 [06928] | INFO | > Installed 3 hook(s). 30/09/2015 13:03:17:655 [06928] | INFO | Redirecting 'D3D10CreateDevice(01F1B398, 0, 00000000, 0x1, 29, 0019F9A8)' ... 30/09/2015 13:03:17:655 [06928] | INFO | > Passing on to 'D3D10CreateDeviceAndSwapChain': 30/09/2015 13:03:17:655 [06928] | INFO | Redirecting 'D3D10CreateDeviceAndSwapChain(01F1B398, 0, 00000000, 0x1, 29, 00000000, 00000000, 0019F9A8)' ... 30/09/2015 13:03:17:655 [06928] | INFO | Redirecting 'D3D11CreateDeviceAndSwapChain(01F1B398, 0, 00000000, 0x40000001, 0019F2D8, 1, 7, 00000000, 00000000, 0019F2E8, 00000000, 00000000)' ... 30/09/2015 13:03:17:762 [06928] | WARN | Reference count for 'IDXGIDevice' object 06B09480 is inconsistent: 2 vs 0. 30/09/2015 13:03:17:762 [06928] | WARN | Reference count for 'ID3D11Device' object 01F10678 is inconsistent: 1 vs 0. 30/09/2015 13:03:17:808 [06928] | INFO | Redirecting 'CreateDXGIFactory({7B7166EC-21C7-44AE-B21A-C9AE321AE369}, 0019F970)' ... 30/09/2015 13:03:17:808 [06928] | INFO | Redirecting 'D3D11CreateDevice(01F19408, 0, 00000000, 0x1, 0019F960, 1, 7, 0019F948, 0019F950, 0019F94C)' ... 30/09/2015 13:03:17:808 [06928] | INFO | > Passing on to 'D3D11CreateDeviceAndSwapChain': 30/09/2015 13:03:17:808 [06928] | INFO | Redirecting 'D3D11CreateDeviceAndSwapChain(01F19408, 0, 00000000, 0x1, 0019F960, 1, 7, 00000000, 00000000, 0019F948, 0019F950, 0019F94C)' ... 30/09/2015 13:03:17:827 [06928] | INFO | Redirecting 'RegisterClassW(0019FD04)' ... 30/09/2015 13:03:17:827 [06928] | INFO | > Adding 'CS_OWNDC' window class style flag to 'Turbine Device Class'. 30/09/2015 13:03:17:858 [06928] | INFO | Redirecting 'IDXGIFactory::CreateSwapChain(01F0FEC0, 01F10588, 0019FA4C, 0019FA94)' ... 30/09/2015 13:03:17:861 [06928] | INFO | Recreated effect environment on runtime 06B674E8. 30/09/2015 13:03:18:424 [06928] | INFO | Redirecting 'RegisterClassW(0019FD2C)' ... 30/09/2015 13:03:18:424 [06928] | INFO | > Adding 'CS_OWNDC' window class style flag to 'Turbine Device Class'. 30/09/2015 13:03:20:406 [06928] | INFO | Redirecting 'RegisterRawInputDevices(736360D0, 1, 12)' ... 30/09/2015 13:03:20:406 [06928] | INFO | Redirecting 'RegisterRawInputDevices(736360A0, 1, 12)' ... 30/09/2015 13:03:20:411 [06928] | INFO | Redirecting 'IDXGIFactory::CreateSwapChain(01F0FEC0, 01F10588, 0019FA90, 0019FAD8)' ... 30/09/2015 13:03:20:411 [06928] | WARN | > Multisampling is enabled. This is not compatible with depthbuffer access, which was therefore disabled. 30/09/2015 13:03:20:413 [06928] | INFO | Recreated effect environment on runtime 0CF34780. 30/09/2015 13:03:22:472 [06928] | INFO | Redirecting 'IDXGISwapChain::SetFullscreenState(0CF23E58, TRUE, 00000000)' ... 30/09/2015 13:03:23:219 [06928] | INFO | Loading effect from "C:\Program Files (x86)\Turbine\The Lord of the Rings Online\ReShade.fx" ...
Posted 8 years, 3 months ago
OK the issue is resolved. For anyone else that gets this issue my solution was this: I ran DXSETUP.exe from directx_Jun2010_redist even though it appeared as though no files were missing and that solved this issue.
New post

Please log in to post an answer